Google App Engine – Eclipse plugin issues

When you start with a maven project and import that into Eclipse, you might run into issues while importing. You might get An internal error occurred during: “Updating Maven Project”. java.lang.NullPointerException right after you do a maven import. If that is the issue, make sure you have installed the “appengine m2e plugin” and the App Engine SDK. Then delete your .metadata directory and .project file. And redo the import. This time it should take more than a minute as Maven starts downloading all the required dependencies.

Then you should be able to import the project without errors and run the project by right clicking and selecting ‘run on server’ -> ‘Google App Engine’. If the project didn’t import correctly, you might get Error: Could not find or load main class com.google.appengine.tools.development.DevAppServerMain error. More on that here. Just repeat the above steps to fix the error.

Advertisements

One Response to Google App Engine – Eclipse plugin issues

  1. Poornima says:

    This solution worked perfect for me. Thanks a lot for the information

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: